CentOS 6 에서 php 5.6으로 업그레이드하기

dokuwiki 를 설치하는데 install.php 가 505 에러가 뜨면서 안된다..
확인해보니.. php 버전이 낮더라..
기본 CentOS 6 에는 php 5.3.3이 깔려있음.

# lsb_release -a
LSB Version:	:base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Distributor ID:	CentOS
Description:	CentOS release 6.9 (Final)
Release:	6.9
Codename:	Final

# php -v
PHP 5.3.3 (cli) (built: Mar 22 2017 12:27:09) 
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
[root@olddos-bbs html]# yum --enablerepo=remi-php56 install php
Loaded plugins: fastestmirror, refresh-packagekit, security

아래와 같이 업그레이드..

# rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm
# yum remove php-common php php-gd php-xml
# yum install -y php56w php56w-xml php56w-mcrypt php56w-gd php56w-devel php56w-mysql php56w-intl php56w-mbstring
# service httpd restart

단 yum install 중에.. 아래와 같이 에러가 뜨면..

Error: php56w-common conflicts with php-common-5.3.3-49.el6.x86_64
Error: Package: libmcrypt-2.5.8-13.el7.x86_64 (epel)
           Requires: libc.so.6(GLIBC_2.14)(64bit)

php56w-mcrypt 빼고 설치할것.

이 글은 카테고리: Linux에 포함되어 있습니다. 고유주소를 북마크하세요.

댓글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다


This site uses Akismet to reduce spam. Learn how your comment data is processed.